Running UT2004 on Windows 10

UT2004 related discussions
Lagzilla
Posts: 8
Joined: Wed 6. Apr 2016, 23:18

Re: Running UT2004 on Windows 10

Postby Lagzilla » Wed 6. Apr 2016, 23:39

Cat1981England wrote:I don't have win10 so i don't know if this will work, but you could try changing the all the Device=D3DDrv.D3DRenderDevice lines in unrealed.ini to Device=OpenGLDrv.OpenGLRenderDevice :dunnosoz:


Thank you, I did bumble into that. Sadly, the editor says it won't work in OpenGL mode. :(

Here is what it looks like. Which is great.

Image

Thanks for the help!!

Andrew

User avatar
Miauz55555
Posts: 777
Joined: Sun 7. Jun 2015, 22:12
Location: Germany

Re: Running UT2004 on Windows 10

Postby Miauz55555 » Wed 6. Apr 2016, 23:46

Are you able to work effective with the editor when it looks like that?
I have still win 7.
Image

Lagzilla
Posts: 8
Joined: Wed 6. Apr 2016, 23:18

Re: Running UT2004 on Windows 10

Postby Lagzilla » Wed 6. Apr 2016, 23:48

Miauz55555 wrote:Are you able to work effective with the editor when it looks like that?


I feel like I am going to puke when it looks like this! lol

Also, it acts squirrely, selecting things is slow, and right click menus are all lagged. It makes me sad.

Andrew

User avatar
Pegasus
Posts: 962
Joined: Wed 4. Nov 2009, 23:37
Description: ONSWordFactory
Location: Greece

Re: Running UT2004 on Windows 10

Postby Pegasus » Thu 7. Apr 2016, 00:07

Perhaps something related to your graphics card's driver/settings may be making UEd try its best 70s-era 3D effect impression? To that end, another test you could try would be, while staying with the D3D renderer, to check your card's control panel for a feature allowing per-program settings customization (both big brands offer it, I believe), and if one exists, manually add UnrealEd.exe in there and set most/all properties to their lowest settings to see if that at least gets it to stop this rendering weirdness.
Image

Lagzilla
Posts: 8
Joined: Wed 6. Apr 2016, 23:18

Re: Running UT2004 on Windows 10

Postby Lagzilla » Thu 7. Apr 2016, 00:49

Pegasus wrote:Perhaps something related to your graphics card's driver/settings may be making UEd try its best 70s-era 3D effect impression? To that end, another test you could try would be, while staying with the D3D renderer, to check your card's control panel for a feature allowing per-program settings customization (both big brands offer it, I believe), and if one exists, manually add UnrealEd.exe in there and set most/all properties to their lowest settings to see if that at least gets it to stop this rendering weirdness.


Red Green stereo!!

I did not see anything in the Nvidia panel for program specific. I did reduce the settings for the monitor it is in and it does not improve despite making things set super low.

I discovered if you resize the viewport it temporarily clears up. As soon as you move around it breaks again. So thats awesome!

Thanks for the suggestion!

Andrew

User avatar
EmanReleipS
Posts: 1400
Joined: Wed 2. Oct 2013, 23:18
Description: Pancake Fairy
Location: Germany

Re: Running UT2004 on Windows 10

Postby EmanReleipS » Thu 7. Apr 2016, 01:13

Thanks, Miau!

Lagzilla wrote:Red Green stereo!!

It's the new 3D feature! :lol:

Andrew, did you see this post from a few pages back?

Btw, I'm also running the editor in compatibility mode for Win 7. :lol:
The wait can be annoying sometimes and it feels like the editor freezes briefly a lot, plus there is a weird battle going on about the screen brightness between the editor (bright) and windows (darker), but all-in-all it's tolerable.
Image

User avatar
Pegasus
Posts: 962
Joined: Wed 4. Nov 2009, 23:37
Description: ONSWordFactory
Location: Greece

Re: Running UT2004 on Windows 10

Postby Pegasus » Thu 7. Apr 2016, 01:15

Lagzilla wrote:[...]I did not see anything in the Nvidia panel for program specific.[...]
After a bit of searching to ensure it's still in the same place as my 4-plus-year-old drivers' settings, it appears you can find this in your nVidia CP's "Manage 3D settings" category, where the first tab, Global Settings, applies the settings to all rendered programs, and the second one, Program Settings, is where you can manually add any specific executable you want, and have its setup deviate from the global values in any way you want. That's where you'd try giving lower settings to UEd.

Still, the fact that resizing the viewports clears it up is good news because it means it's not unsolveable, but probably attributable to a bad mix of interacting factors at one of the 3 stages of the rendering process: OS-to-program compatibility, rendering middleware (DirectX here) and post-rendering effects by the GFX software. If doing the minimum nVidia values test yields no result, that means nV software can be excluded (barring specific driver version problems in general) and some other point in a previous part of the chain is causing the bug. Another thing you could try then is seeing if enabling WinXP/Win7 compatibility for UEd helps any.
Image

Lagzilla
Posts: 8
Joined: Wed 6. Apr 2016, 23:18

Re: Running UT2004 on Windows 10

Postby Lagzilla » Thu 7. Apr 2016, 02:09

Pegasus wrote:
Lagzilla wrote:[...]I did not see anything in the Nvidia panel for program specific.[...]
After a bit of searching to ensure it's still in the same place as my 4-plus-year-old drivers' settings, it appears you can find this in your nVidia CP's "Manage 3D settings" category, where the first tab, Global Settings, applies the settings to all rendered programs, and the second one, Program Settings, is where you can manually add any specific executable you want, and have its setup deviate from the global values in any way you want. That's where you'd try giving lower settings to UEd.

Still, the fact that resizing the viewports clears it up is good news because it means it's not unsolveable, but probably attributable to a bad mix of interacting factors at one of the 3 stages of the rendering process: OS-to-program compatibility, rendering middleware (DirectX here) and post-rendering effects by the GFX software. If doing the minimum nNidia values test yields no result, that means nV software can be excluded (barring specific driver version problems in general) and some other point in a previous part of the chain is causing the bug. Another thing you could try then is seeing if enabling WinXP/Win7 compatibility for UEd helps any.


Thanks for the tip. Missed that tab for sure.

I have to go to work, when I get back I will experiment.

What I can say is... I turned everything off or all the way down. Some of the meshes show up blocky and weird, but the R-G stereo thing is now gone. The editor still acts sluggishly as well.

As I said, I will work on adjusting some more stuff and see if I can re-break it to let others know should they encounter this issue.

Thank you so much for your help, it is truly appreciated.

Andrew

User avatar
Miauz55555
Posts: 777
Joined: Sun 7. Jun 2015, 22:12
Location: Germany

Re: Running UT2004 on Windows 10

Postby Miauz55555 » Thu 7. Apr 2016, 10:17

Have you installed UT direct under the root (like C:\UT2004)? Wormbo mentioned, somewhere in this topic, that when it's installed in a subfolder or with blanks it could cause problems.

Can you post your hardware (Motherboard, CPU, GPU)?

Do you have an overall reduced system performance since win 10? My opinion is when you have new componets and want to use win you have to use win 10 to get all the performance which is available. But with "old" (4/5 years) componets you will have a performance loss.

I'm not sure, but i think Smalltown had said that when you make a clean install from win 10 it's running better than with the upgrade thing.

With the red/green thing you can use a red/green_goggle. :lol: Sorry. :angelwings: It really looks like your GPU is producing an old red/green 3D effect. Has UT this "feature"?
What I found is that this driver IZ3D could be used to made a red/green-3D to 2D programms. Also to UT. Just scroll to the picture.

Btw. wellcome to the forum.
Image

Lagzilla
Posts: 8
Joined: Wed 6. Apr 2016, 23:18

Re: Running UT2004 on Windows 10

Postby Lagzilla » Thu 7. Apr 2016, 22:45

Miauz55555 wrote:Have you installed UT direct under the root (like C:\UT2004)? Wormbo mentioned, somewhere in this topic, that when it's installed in a subfolder or with blanks it could cause problems.


My copy is from Steam.


Miauz55555 wrote:Can you post your hardware (Motherboard, CPU, GPU)?

Sure:
i7-4790S 3.2 GHz
12GB Ram
4TB HDD
nVidia GTX660Ti


Miauz55555 wrote:Do you have an overall reduced system performance since win 10? My opinion is when you have new componets and want to use win you have to use win 10 to get all the performance which is available. But with "old" (4/5 years) componets you will have a performance loss.


Not at all. 3DSMax, Blender and so on all work tops. Corel works good, but the menus are jacked up. InDesign works great too.

Miauz55555 wrote:I'm not sure, but i think Smalltown had said that when you make a clean install from win 10 it's running better than with the upgrade thing.

With the red/green thing you can use a red/green_goggle. :lol: Sorry. :angelwings: It really looks like your GPU is producing an old red/green 3D effect. Has UT this "feature"?
What I found is that this driver IZ3D could be used to made a red/green-3D to 2D programms. Also to UT. Just scroll to the picture.

Btw. wellcome to the forum.


Yeah, I tried it with the glasses, no luck for me ;)

Thanks for the welcome. And thank you all for the great help and pointers!

Andrew


Return to “General”



Who is online

Users browsing this forum: No registered users and 3 guests