Running UT2004 on Windows 10

UT2004 related discussions
Lagzilla
Posts: 8
Joined: Wed 6. Apr 2016, 23:18

Re: Running UT2004 on Windows 10

Postby Lagzilla » Thu 7. Apr 2016, 22:48

So after extensive setting tweaking I can tell you this for sure. I have no idea why it was doing this.

I used "restore" to get the defaults and the editor works fine.

I put the max selections on all settings.... and it works fine. I don't get it.

Thanks again everyone for the pointers and input! I can now get back to work on these maps!!

Andrew

User avatar
Pegasus
Posts: 955
Joined: Wed 4. Nov 2009, 23:37
Description: ONSWordFactory
Location: Greece

Re: Running UT2004 on Windows 10

Postby Pegasus » Fri 8. Apr 2016, 00:54

Glad it all worked out. Let us know if you need any more help with UEd or some other kind of mapping issue.

Oh, and, like already said, welcome to the msg. board.
Image

User avatar
ikaa
Posts: 4
Joined: Sat 5. Sep 2015, 20:30
Description: Old player

Re: Running UT2004 on Windows 10

Postby ikaa » Mon 20. Jun 2016, 14:58

CrazySacrifice wrote:If the game works fine on windowed mode (win10) and crashes in fullscreen you can solve it by changing ReduceMouseLag to False in ut2004.ini

works for me ^^

_____________
thanks Great help
it works now :)

User avatar
Hawk
Posts: 45
Joined: Mon 7. Apr 2014, 21:59
Description: Fly like an eagle euh hawk :p
Location: Country of fries :o)

Re: Running UT2004 on Windows 10

Postby Hawk » Tue 2. Aug 2016, 17:26

ikaa wrote:
CrazySacrifice wrote:If the game works fine on windowed mode (win10) and crashes in fullscreen you can solve it by changing ReduceMouseLag to False in ut2004.ini

works for me ^^

_____________
thanks Great help
it works now :)


Or just open it in a small window, go to tab INPUT and uncheck the box REDUCEMOUSELAG. That works fine too
Hawk
Free as a bird

User avatar
Hawk
Posts: 45
Joined: Mon 7. Apr 2014, 21:59
Description: Fly like an eagle euh hawk :p
Location: Country of fries :o)

Re: Running UT2004 on Windows 10

Postby Hawk » Tue 2. Aug 2016, 17:38

Cat1981England wrote:I'm still on win7 and don't know anything about this, but isn't having that enabled a huge security risk?


Yep win 10 uses your computer and bandwith to do updates on other computers if they find it necessary.
The stupid thing is that when you install win 10, microsoft activates all this. You have to click custom install (written in tiny letters) and uncheck all the boxes. There are a bunch that are shit. You can't believe your eyes if you read what standard would be activated.
I did not do upgrade, I installed it clean on a different Harddisk to get my free code activated. For the moment I have dual boot for WIn7 and WIN 10.
Hawk
Free as a bird

User avatar
smalltown
Posts: 79
Joined: Mon 1. Aug 2011, 08:18
Description: UT 2004 cunt player
Location: United Kingdom

Re: Running UT2004 on Windows 10

Postby smalltown » Fri 9. Sep 2016, 01:50

I have just one problem everytime I launched the game, it starts with the windowed version rather than the fullscreen. So as a result, I have to click on the maximize icon to get the fullscreen...
:firedevil: :firedevil: STOMBOTOWN :firedevil: :firedevil: :machinegun: :cool2cool: :yoman:

spike
Posts: 1
Joined: Wed 21. Dec 2016, 16:39
Description: Spike

GamersGate ECE Edition on WIndows 10 , my fixes, may help someone...

Postby spike » Sat 31. Dec 2016, 20:33

Hi All,

I bought a copy of UT2004 from GamersGate recently :)

Had a few problems with the install on Windows 10 and with the new map pack (Dec 2016) crashing the game on launch though.

Anyway i found a fix for windows 10 and a couple of fix for the GamersGate ECE edition game launching after downloading the latest map pack...

1. On windows 10 install the game to C:\8.3 folder name. eg... C:\UT2004
This fixed the windows 10 issues (prob permissions). Installing in "C:\Program FIles(x86)\Unreal Tornament 2004" (is a no go ... Cache folder not created or log file etc etc)

2. The Primeval_SM.usx file is wrong on install from the GamersGate copy or not working according to the logs. I downloaded a version from the web. 208KB is the working game file size.

3. The version from GamersGate had the X-AW-Cubes.utx or AW-Cubes.utx missing issue. I had a copy from a game version installed elsewhere and these worked fine.

4. If you have a Full HD screen (1080P) , alter the "System\UT2004.ini" and change the following settings :
FullscreenViewportX=1920
FullscreenViewportY=1080

5. In "System\UT2004.ini" i set the option ReduceMouseLag=False under the section [D3DDrv.D3DRenderDevice].

If you have other issues check the UT2004.log file in the system directory for warning lines posted...

Hope you all have a happy New Year.

Kill you soon.
Spike.

User avatar
Xac
Posts: 529
Joined: Thu 15. Nov 2012, 14:21
Description: keeping it UNreal since 2004

Re: Running UT2004 on Windows 10

Postby Xac » Mon 16. Jan 2017, 19:27

On all the computers I've played UT on with Win10, the brightness, contrast and gamma are disabled and cannot be adjusted. Many maps appear very dark, some are almost unplayable (see picture below). Has anyone with Win10 been able to overcome this problem? The picture was taken using my phone and it actually adjusted the brightness to make it look lighter than by eye.

Apart from Zoner's sage advice, you can't see much ;)
Attachments
Playing with win10.JPG
Playing with win10.JPG (72.75 KiB) Viewed 831 times
I tried to drown my sorrows, but somehow they learned how to swim...

User avatar
Miauz55555
Posts: 681
Joined: Sun 7. Jun 2015, 22:12
Location: Germany

Re: Running UT2004 on Windows 10

Postby Miauz55555 » Tue 17. Jan 2017, 00:26

I don't have WIN10, but I installed recendly UT2k4 on 4 WIN10 systems wile my litle bro had a lan-party. Laptop and Desktop systems. And on not one I saw that thing.
I only had let them put all files under the root (c:\) or a partition where they have full writing rights.. set the fullscreen to fals and the reduce mouse lag also. Than put the registry entrys in place and run... All fine.

Things what you should try:
  1. Files under the root?
  2. If not move theme there (C:\UT2004) and correct the registry entry. To do so type "regedit" in your start field and run the programm which appear. The Data are under:
    "HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Unreal Technology\Installed Apps\UT2004"
  3. Correct the path under "Folder". It should look like: "C:\UT2004" No space in the path.
  4. Go to your Ut2004/System Folder and move the user.ini and ut2004.ini to your desktop, delete the unrealED.ini... maybe your defaulte inis are corrupt as well... Move your Default.ini, DefUnrealED.ini and DefUser.ini to your desktop (or somewhere else) {Well ... move ALL your .ini-files to your Desktop to test it} and copie that one I upload here to your system folder [I changed the reduce mouse lag and start full screen to falls also the purgecache days to 0] (so you can move them back if my don't work for you.. really don't know if GOG,Steam or so have modivied versions.)
  5. Run the Game.
  6. When fine open your original user.ini go to [Engine.PlayerController] StatsUsername and
    StatsPassword for your Epic Game ID to put the values inside your new user.ini or ingame in the related option.
  7. Inside your ut2004.ini under [XInterface.ExtendedConsole] you will find your faforite servers which you can put inside your new ut2004.ini when the game is closed. [I put the CEONSS-server inside the .ini].
Def.ini.7z
(8.55 KiB) Downloaded 39 times
Image

User avatar
Xac
Posts: 529
Joined: Thu 15. Nov 2012, 14:21
Description: keeping it UNreal since 2004

Re: Running UT2004 on Windows 10

Postby Xac » Tue 17. Jan 2017, 10:08

Thanks for the advice Miau, I'll give it a try. I'm wondering if it's the version of UT that I've got that is the problem. I have the Unreal Anthology, so when you click on the UT icon, it launches a window which you can then select the various UT games, from the original back in the 90s, to UT2004. I never play those older games, so maybe I need to set it up so that UT2004 launches directly?

When I get the chance, I'll have a look :thumbup:
I tried to drown my sorrows, but somehow they learned how to swim...


Return to “General”



Who is online

Users browsing this forum: No registered users and 2 guests