Running UT2004 on Windows 10

UT2004 related discussions
User avatar
Xac
Posts: 537
Joined: Thu 15. Nov 2012, 14:21
Description: keeping it UNreal since 2004

Re: Running UT2004 on Windows 10

Postby Xac » Wed 18. Jan 2017, 13:42

Success!! I copied the UT2004 out of the Unreal Anthology folder directly to the C:\ drive and did the regedit you suggested and now it works, I can adjust brightness, contrast and Gamma once again. :D :dancegal: :yippiiieh: :wohoo:

Thanks Miau you little genius! :lol: :clap:

I didn't need to try your ini files to get it to work. I already had reduce mouse lag as false and purge=0 in the ini file, was there anything else useful you had in your ini files which would be worth changing on mine? Someone said something about changing server tick rates a while back, would that help?
I tried to drown my sorrows, but somehow they learned how to swim...

RottenToTheCore
Posts: 258
Joined: Fri 6. Jan 2012, 12:57
Description: Not related to Power-Cores ;)

Running UT2004 on Windows 10

Postby RottenToTheCore » Wed 17. May 2017, 19:46

Since newest Update that was rolled out some days ago UT2004 wont start in 85hz anymore on my CRT (yes i still play on a crt). Does anyone have an idea how to force a Refresh Rate in Win 10? It's so fucking frustrating.

Crazy_Eddie
Posts: 11
Joined: Tue 10. Jan 2017, 15:40
Description: Never learns.

Running UT2004 on Windows 10

Postby Crazy_Eddie » Thu 18. May 2017, 15:25

Settings -> System -> Display -> Display adapter properties -> (a new window pops up) -> "Monitor" tab -> pick your screen refresh rate from the drop-down.

RottenToTheCore
Posts: 258
Joined: Fri 6. Jan 2012, 12:57
Description: Not related to Power-Cores ;)

Running UT2004 on Windows 10

Postby RottenToTheCore » Fri 19. May 2017, 20:41

Hey Crazy :),

that won't do it :/. That's too easy :mrgreen: . Even on my 120hz monitor ut will only run in 75hz. Same goes for other old games like GTA-SA and even newer shooters like Borderlands 2. Before the update all was fine in 120hz.

I heard that microsuck added some game mode, perhaps this screwed everything?

User avatar
Miauz55555
Posts: 933
Joined: Sun 7. Jun 2015, 22:12
Location: Germany

Re: Running UT2004 on Windows 10

Postby Miauz55555 » Fri 19. May 2017, 21:07

Maybe you could force it with your GPU driver, specified for the programm?
Image

Crazy_Eddie
Posts: 11
Joined: Tue 10. Jan 2017, 15:40
Description: Never learns.

Running UT2004 on Windows 10

Postby Crazy_Eddie » Tue 23. May 2017, 14:53

RottenToTheCore wrote:Hey Crazy :),

I heard that microsuck added some game mode, perhaps this screwed everything?


I haven't played with it, but there's Windows Game Mode. I believe you can turn this on/off with Win-G.

Otherwise, follow Miauz's advice and look for a control panel specific to your graphics adapter. In my case, it's "intel HD Graphics Control Panel". That may have the additional setting you need.

Edit: I just thought of something else. Are you trying to play in a window or fullscreen? Because I get radically different rendering between the two.

RottenToTheCore
Posts: 258
Joined: Fri 6. Jan 2012, 12:57
Description: Not related to Power-Cores ;)

Running UT2004 on Windows 10

Postby RottenToTheCore » Mon 5. Jun 2017, 12:43

Hey guys, the Display Driver Properties are - of course - the first things i check and update. Nothing would help at all. I now uninstalled the creator's update and everything went back to fine :)

Crazy_Eddie
Posts: 11
Joined: Tue 10. Jan 2017, 15:40
Description: Never learns.

Re: Running UT2004 on Windows 10

Postby Crazy_Eddie » Fri 16. Jun 2017, 11:33

Just found this tutorial. It may be relevant to someone with issues displaying UT2K under Win 10:

https://www.cnet.com/how-to/6-display-s ... indows-10/

Good luck!

User avatar
SysX
Posts: 41
Joined: Sat 4. Mar 2017, 08:59
Location: Holland / Netherlands

Re: Running UT2004 on Windows 10

Postby SysX » Wed 21. Jun 2017, 15:30

Only issue I had on w10 was the lack of sound (no sound at all), if you encounter this issue you have to download the OpenAll driver and uncheck 'system driver' in the ut menu -> audio settings.
Commercialized Killer!!!

User avatar
Miauz55555
Posts: 933
Joined: Sun 7. Jun 2015, 22:12
Location: Germany

Running UT2004 on Windows 10

Postby Miauz55555 » Sun 22. Oct 2017, 14:47

I may share this for the win10 users:

"Original from agribah at HoC." If you've recently installed the Fall Creator's Update for Windows 10, congrats. You've unwittingly turned on Gaming Mode (which used to be an optional feature with a convenient little slider to disable it) Now instead by default, all your games start using this new Microsoft feature, and if you want to disable it, you have to do so individually for each game. Why does it matter? If you've played around with Gaming Mode at all you know it can dramatically change your game experience (... your aim in particular? ). Thanks for pushing an unproven feature on me Microsoft.

You can check if you've got the Update installed by going to Start > Settings > System > About and scrolling down until you find this:
Image
If the Version number is 1709, congrats, you're shit-aim approved until you turn off Game Mode.

To turn it off you'll have to look in Start > Settings > System > Gaming to adjust the key combo (default Win + G) that brings up the Game Mode OSD in game. Bring up that menu while in UT, and disable Game Mode by clicking the gear icon and unchecking "Use Game Mode for this game".

Phew... Thanks for wasting my time Microsoft.


"Original from Tichinde925 at HoC." Here's another:
https://www.reddit.com/r/PUBATTLEGROUNDS/comments/71gzpi/greatly_improve_fps_new_method/
Quote:
I've found a reasonably big fps booster, at least for myself. So I want to share it at least, even you dont have issues atm, I'd suggest at least to give a try.
Head to C:\Program Files (x86)\Steam\steamapps\common\PUBG\TslGame\Binaries\Win64
Right click to properties on "TslGame"
Navigate to Compatibility -> check the "override high DPI scaling behavior" box, and hit "OK". (Application from drop-down menu)
Image
Restart your game if necassery.
And now you should have greatly higher FPS, without making graphics look any worse AT ALL! - This also works with other games if you are having performance issues and know your hardware should run it better than that.
For me, I had 30-40 FPS at starter island before game starting, and game responsiveness was mehh, but now it is around 50-55 with vsync on, even after I upped a bit some settings! In game running perfectly with 60FPS.
Image


Return to “General”



Who is online

Users browsing this forum: No registered users and 1 guest