Very slow selection in 3D viewport of UnrealEd

Anything about UT2004 mapping, Uscripting & more
User avatar
Crusha K. Rool
Posts: 118
Joined: Sun 28. Aug 2011, 23:14
Description: Coding Crocodile
Location: Germany

Very slow selection in 3D viewport of UnrealEd

Post by Crusha K. Rool »

Anyone else having this problem? Back in the days the selection in the 3D viewport would be just as fast as the one in the 2D viewport, but nowadays the editor basically hangs for 4-6 seconds every time you try to select something in the 3D viewport (and it's not directly in front of the camera).

I remember having this issue in the past and I think a graphics driver update introduced it for me back then (when I was still on nVidia). I don't really remember if it got solved by another driver update or not. Or maybe it was a DirectX version issue...?

Anyway, just makes mapping a little bit of a pain. And I guess I wanted to vent some frustration. :/
User avatar
Cat1981England
Posts: 2326
Joined: Mon 23. Aug 2010, 15:35

Re: Very slow selection in 3D viewport of UnrealEd

Post by Cat1981England »

I have the same problem on some maps. I've found that it helps to turn off volumes or static meshes depending on which one you are trying to grab.
The Universal Declaration of Human Rights, Article 1:

All human beings are born free and equal in dignity and rights. They are endowed with reason and conscience and should act towards one another in a spirit of brotherhood.
User avatar
GLoups!
Posts: 570
Joined: Fri 3. Feb 2012, 17:57
Description: Just play for fun.
Location: Fr

Re: Very slow selection in 3D viewport of UnrealEd

Post by GLoups! »

May be it has nothing to do with it, never had this issue on few pcs excepting if you zoom too wide on one Ued window....?

Edit: This also depends on the direction in which you select and what is behind the selected object.
User avatar
EmanReleipS
Administrator
Posts: 2751
Joined: Wed 2. Oct 2013, 23:18
Description: Pancake Fairy
Location: Germany

Re: Very slow selection in 3D viewport of UnrealEd

Post by EmanReleipS »

I've been getting freezes all the time since updating to Win10. Thanks to Wormbo I've reduced them from 30 seconds to 5ish. Guess I will be selecting stuff solely in the 2D viewports from now on. :|
Image
User avatar
Crusha K. Rool
Posts: 118
Joined: Sun 28. Aug 2011, 23:14
Description: Coding Crocodile
Location: Germany

Re: Very slow selection in 3D viewport of UnrealEd

Post by Crusha K. Rool »

Aside from not even having an option in the AMD Crimson driver to forcefully disable AA, it wasn't enabled in the first place (and enabling it didn't actually impact the selection time for me). It seems to depend on how many objects are in the scope of the viewport to be deprojected onto the screen. So whenever I need to select something in the 3D viewport, I better make sure to look at the ground and have as few other things as possible in the background.
User avatar
Miauz55555
Posts: 1687
Joined: Sun 7. Jun 2015, 22:12
Location: Germany

Very slow selection in 3D viewport of UnrealEd

Post by Miauz55555 »

WIN 10; RTX2070; i5 9600K

So following some of theese there:
https://www.epicgames.com/unrealtournam ... s-10/page5
I have no real solution for that.

What is working is to start win 10 in save mode (5). There the selecting is instand. Just the view while moving is a bit mushy as the drivers are disabled there.

I also tried the "use the intern-GPU" .. but with the newest drivers, it wasn't working better as with the PCIE-GPU.
Also using an 4:3 aspect ratio was helping, but just a split seccond less .. so not good.

I'm not so happy with the save mode solution, but I'm much more unhappy to click and wait, or zoom in click and wait shorter, or to cut a map in pieces and put it together later.
So when someone has a better solution, please speak out.

-----
P.S.: Disable your PCIE-GPU is stupid if you haven't pluged in your monitor also to the mobo-gpu AND activate as well as installed it. With other words, don't do that .. it's a Laptop thingy.
Image